PHP Extension pcntl


(ComercioSite.com) #1

Friends I’m having error in PHP Extension pcntl, the magento setup does not continue until I install this extension.
I searched the forums and google and everyone I installed continues giving error.
Any suggestions from friends to pcntl Extension?
I’m in Brazil and I’m watching all of Craig’s videos, I’m a fan. Congratulations Craig for the great teaching.


(Craig) #2

Hey there, welcome to the community :+1:

Out of all the Magento 2 installations I’ve done, I have never come across this error. Infact, the PCNTL extension isn’t even listed as a requirement on the Official Magento Documentation.

Potential Cause
From the very limited research I’ve done whilst composing this reply, I believe PCNTL is always packaged with PHP by default when installing PHP via a Repository. However, PCNTL can sometimes be overlooked if PHP is compiled directly onto the server instead.

Potential Solution A
I have also noticed (on your screenshot), that you are running PHP v7.0.30. I’ve never actually installed Magento 2 with anything less than PHP v7.1. You might be able to resolve your issue by upgrading your version of PHP. It’s also important to note that the upcoming update of Magento 2.3 will be dropping support for PHP v7.0 - So you may as well deal with that now.

For more information on learning how to upgrade PHP 7.0 to 7.1 on Ubuntu 16. You might find this article useful. I’ve had to refer to it myself in the past and it works fine.

Potential Solution B
If you don’t want to try upgrading your version of PHP just yet, then I found this post on stackoverflow that may (or may not help).

Please, do let us know how you get on.

Usual Disclaimer: Make sure you backup your server before making any changes


(ComercioSite.com) #3

Hello Craig, Thanks for the tips and the speed of return.
I tried to change php 7.0 to 7.2 did not work, because magento 2.2.5 does not recognize. I deleted everything on the server and started again with php 7.1 now running normally.
I’m doing the updates by following your videos that are excellent and recommended.
in the air: www.loja.vidafashionboutique.com
I will try to keep the default theme (luma) of the magento, because if it has updates in magento it is easier to update.

I’ll try to leave the magento similar to this vidafashionboutique.com

Thank you

Samuel


(Ömer Akdeniz) #4

hi
sudo apt-get install php libapache2-mod-php php-mcrypt php-mysql php7.0-soap php7.0-bcmath -y

I am having the same problem.

Can I install the above command as 7.2

7.0 I have moved 7.2 problem not solved

thank you
ömer


(Craig) #5

@omrakdeniz, Magento 2.2.x will only work with these 2 versions of PHP:

  • 7.0.13–7.0.x
  • 7.1.x

@comerciosite was able to solve his issue by specifically installing PHP 7.1

On a side-note
When Magento 2.3.x is released it will only support the following PHP versions:

  • 7.1.3+
  • 7.2.x

(Ömer Akdeniz) #6

hello about mcrypt problem.
mysql with php.
sudo phpenmod mcrypt does not work
I didn’t get 20 server results
php 7.2 problematic mcrypt

I’ll try php 7.1 in the way I’m your carig.

you want to look at the screenshot of the error I got
Thank you for your interest.